禁止wordpress把"–"自动转换成"-"

2010年03月29日 Wordpress 评论 1 条 阅读 6,074 views 次

最近写了几篇文章,根据网友的反应,说代码不能直接复制使用,检查才发现是因为wordpress自动把"--"转换成"-",这当然不行啊,特别是我们在写一些代码性的文章的时候!所以我今天就咨询了一下GOOGLE,最后找到解决的办法了,特拿出来和大家分享!修改wp-includes/formatting.php


$curl = str_replace($static_characters, $static_replacements, $curl);
$curl = preg_replace($dynamic_characters, $dynamic_replacements, $curl);

这两行给注释掉
//$curl = str_replace($static_characters, $static_replacements, $curl);
//$curl = preg_replace($dynamic_characters, $dynamic_replacements, $curl);

就把这个自动转换功能给禁止掉了,但是每次升级的时候,都要记得改这个文件,如果说忘记改了,就又会自动转换,如果说你觉得这样麻烦的话,就用“Quotmarks Replacer”这个插件。
本人不喜欢插件,所以我选择给修改文件,如果你觉得修改文件麻烦的话,就用插件吧。不过,插件我自己没有测试,大家自己动手实验吧!适合自己的,才是最好的!

1 条留言  访客:0 条  博主:0 条   引用: 1 条

来自外部的引用: 1 条

  • 隐藏/屏蔽服务器信息与web软件版本信息Radhat/CentOS教程 | Linux服务器 | PHP教程 | Mysql/Oracle资料 | Jquery开源资料 |冰封博客

给我留言

Copyright © 羽飞博客 保留所有权利.   Ality主题 皖ICP备14013844号-1

用户登录