在linux/unix系统上安装Openmeetings免费视频会议第一版

2010年03月13日 Linux服务器 评论 50 条 阅读 110,847 views 次

在开始前我们来了解一下Red5和Openmeetings
Red5是一款基于JAVA的免费的开源的Flash流媒体server.是当前最好的替代Adobe提供的FMS的开源软件。而且在可扩展性上有FMS不可比拟的优势。
Openmeetings是一款基于Flex开发的开源视频软件,通过RTMP和HTTP协议传送视频数据。支持在线聊天,视频,文件共享,桌面共享。支持多语言。
接下来,我们来看看需要哪些相关软件
1. Mysql 这个是数据库,离开它,那什么也干不成。
2.JDK最新版本,Openmeetings就是基于它来运行的。下载地址:http://java.sun.com/javase/downloads/index.jsp
3. ANT 最新版本,(非必需。如果你需要编译安装Openmeetings的话,就需要此软件)。
4.Red5最新版本,基于JAVA的免费的开源的Flash流媒体server。下载地址:http://www.red5.org/downloads/0_9/red5-0.9.1.tar.gz
5.Openmeetings最新新版,这个是本文的关键。下载地址:http://code.google.com/p/openmeetings/downloads/list
6. OpenLaszlo 最新版本(非必需,如果你需要Openmeetings的客户端的话,就需要这个),OpenLaszlo 是一种富客户机应用程序架构,使用MacromediaFlash作为部署载体。下载地址:http://www.openlaszlo.org/download
7. SVN 著名的版本管理工具Subversion,用来下载OpenMeetings的源代码的。(非必需)
8. OpenOffice.org 最新版本。openmeetings有一个很特色的功能就是白板功能,在线共享诸如ppt,word,excel等office文档,这部分的功能就是由openoffice来进行支持的。下载地址:http://zh.openoffice.org/new/zh_cn/downloads.html

其它与Openmeetings相关的软件

9. ImageMagick :是一个图象处理软件。它可以编辑、显示包括JPEG、TIFF、PNM、PNG、GIF和Photo CD在内的绝大多数当今最流行的图象格式。协助openoffice提供在线共享图片功能。http://www.imagemagick.org
10. GhostScript: 阅读开放性文件格式(如pdf)的软件。协助openoffice提供在线共享pdf功能。http://ghostscript.com/releases/
11. SWFTools:将pdf文档转为flash格式在白板中播放。http://www.swftools.org/download.html
12. FFMpeg:是用于录制、转换和流化音频和视频的完整解决方案,包括libavcodec ,一套领先的音/视频编解码类库。协助openoffice提供会议录制功能。http://www.ffmpeg.org
13. SoX: 用于录制功能。http://sox.sourceforge.net
14. Flash Player 所有这些都是基于FALSH的,http://get.adobe.com/flashplayer/otherversions/

以上软件都准备好了后,我们就开始进行安装了!
大家注意,我这里没有下载Openmeetings的客户端,因为我在官方的网上找不到具体是哪个,试了几个,都没有实现,最后我把服务端改造了一下,但最终的客户端和服务端是一样,如果你知道的话,希望与我联系,谢谢!

先来规划一下系统的安装路径,所有软件存放的位置/root/soft,openmeetings的安装位置是/openmeetings,/openmeetings/red5,/openmeetings/jdk,/openmeetings/lps
apache-ant-1.8.0-bin.tar.gz              OOo_3.2.0_LinuxIntel_install_zh-CN.tar.gz
openlaszlo-4.7.1-unix.tar.gz         openmeetings_1_1_r3087.zip
ffmpeg-0.5.1.tar.bz2                     ghostscript-8.70.tar.bz2
flash-plugin-10.0.45.2-release.i386.rpm  swftools-0.9.0.tar.gz
ImageMagick-6.6.0-4.tar.bz2              jdk-6u18-linux-i586.bin
以上这些可以用yum或者是apt-get进行安装,如果在源中找不到的,大家可以用源码安装
下面我给出两个源
1、centos
下载这个文件,然后进行安装,http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.1-1.el5.rf.i386.rpm
2、debian
deb  http://mirrors.163.com/debian/ lenny-proposed-updates main contrib non-free
deb  http://mirrors.163.com/debian-security lenny/updates main contrib non-free
deb-src  http://mirrors.163.com/debian/ lenny main contrib non-free
deb-src  http://mirrors.163.com/debian/ lenny-proposed-updates main contrib non-free
deb-src  http://mirrors.163.com/debian-security lenny/updates main contrib non-free
deb  http://debian.nctu.edu.tw/debian/ lenny main contrib non-free
deb-src  http://debian.nctu.edu.tw/debian/ lenny main contrib non-free
deb  http://security.debian.org/ lenny/updates main contrib non-free
deb-src  http://security.debian.org/ lenny/updates main contrib non-free
deb  http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src  http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

大家可以根据自己的系统来选择,用YUM和APT-GET安装的话,会节省很多时间,还有一点,需要强调一下,就是必需安装桌面环境,否则你的OpenOffice.org安装不上

好了,开始进行安装(以CentOS5.3为例)
1、安装YUM源,并安装桌面环境
wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.1-1.el5.rf.i386.rpm
rpm -ivh rpmforge-release-0.5.1-1.el5.rf.i386.rpm
yum clean all
yum groupinstall "GNOME Desktop Environment" #因为我没有安装桌面,所以我要先安装桌面

2、安装所有需要的软件
yum install -y mysql-server java-1.6.0-openjdk java-1.6.0-openjdk-devel ghostscript swftools ffmpeg ImageMagick subversion sox openoffice.org-core openoffice.org-base openoffice.org-calc openoffice.org-draw openoffice.org-impress openoffice.org-math openoffice.org-writer openoffice.org-graphicfilter openoffice.org-headless

3、设置环境变量
vi /etc/profile
在文件后添加:
//JAVA
JAVA_HOME=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/
PATH=$PATH:$JAVA_HOME/bin
CLASSPATH=$JAVA_HOME/bin/tools.jar:$JAVA_HOME/lib/dt.jar
export PATH CLASSPATH JAVA_HOME
//ant 如果你安装了ant-apache的话,就要根据自己的情况,增加下面两行,也可以和JAVA写在一起
export ANT_HOME=/usr/local/ant
export PATH=$PATH:/usr/local/ant/bin
运行source /etc/profile 使配置生效。

4、设置MYSQL密码
如果说你是debian系统的话,在安装过程中就会提示你输入MYSQL密码
我们是CentOS所以,需要自己设置MYSQL的密码
chkconfig mysqld on
service mysqld start
/usr/bin/mysqladmin -uroot password 123456

这里大家要注意一下:当我们用中文的时候,我们会发现登陆的界面都是error,这里我们来解决这个问题
中文乱码问题解决方法(1、2)
方法1:自己创建数据库,并设置成UTF8编码
mysql>CREATE DATABASE `openmeetings` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
方法2:在mysql的配置文件中增加内容
vim /etc/my.cnf
在相应的位置增加下面的内容
[mysqld]
default-character-set=utf8
character-set-server=utf8
[client]
default-character-set=utf8

这们就解决了中文乱码问题了
5、安装Red5和Openmeetings
我在http://code.google.com/p/openmeetings/downloads/list这里下载了编译好的,而且Red5和Openmeetings在一起的,这样方便多了,也就无需再安装ant了
unzip openmeetings_1_1_r3087.zip
mv red5 /openmeetings/
cd /openmeetings/red5/
chmod u+x red5.sh
chmod u+x red5-shutdown.sh
cd webapps/openmeetings/conf
cp mysql_hibernate.cfg.xml hibernate.cfg.xml
vim hibernate.cfg.xml

把MSYQL用户名和密码改成你自己的
<!-- User  / Password -->
                <property name="connection.username">root</property>
                <property name="connection.password">123456</property>

vim ../config.xml
把下面的内容填上自己的地址
<!--<rtmphostlocal>192.168.254.182</rtmphostlocal>-->
<rtmphostlocal>192.168.1.7</rtmphostlocal>

下面我们就启动Red5,进行安装Openmeetings
cd /openmeetings/red5
/usr/bin/nohup ./red5.sh &

这时候,我们就能查看系统中有了5080端口起来了
我们就可以在浏览器中输入http://192.168.1.7:5080/openmeetings/install进行安装了

点Continue with STEP 1进行安装,(图1)
1
在接下来的配置界面上,其实只需要填上用户名、密码和邮箱就可以,这里面的其它参数可以在Openmeetings的后台进行设置,也是一样的。
我给出我的配置图(2、3、4),没有给出图的,都是默认值
 2

3

4

  然后就INSTALL就开始安装了,这个时间稍长,大概10分钟左右(根据自己的机子而定),不要以为死机啊!耐心等待。
安装完成后如(图5)
5
点Enter the Application后进入登陆界面(图6)
6
如果说,在安装时候,没有配置一些内容,我们可以登陆后,在管理——配置信息中进行重新设置(图7)
7
注意:在使用屏幕共享的时候,如果说你的系统上没有安装JAVA的话,就会提示下载一个文件,下载下来,也不能实现屏幕的共享,这时候你就要下载个JAVA程序,安装到自己的电脑上,然后就能共享你的屏幕了!

6、配置openoffice
第一次安装后,要启动一次Openoffice进行一下相关的初始设置,如果不设置的话,你的Openoffice是不能使用的,这一点,一定要注意。还有要提醒大家的就是,如果你的系统没有中文的话,最好把中文安装上,不然,看到的字都是方块。
在Openmeetings中,如果不设置openoffice启动并使其监听8100端口的话,那么上传文件会出错(图8)
8 
注意:出现错误的主要原因是因为我们的openoffice没有运行并监听8100端口
下面两个命令是针对不同的安装方式的
如果说你是下载RPM包安装的,启动的命令用这个
/usr/bin/nohup /opt/openoffice.org3/program/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard &
如果说你是yum安装的,启动命令用这个
/usr/bin/nohup /usr/lib/openoffice.org/program/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard &
不同之处在就是soffice这个命令的路径不一样

7、安装OpenLaszlo(lps)
tar zxvf openlaszlo-4.7.1-unix.tar.gz
mv lps-4.7.1 /openmeetings/lps
cd /openmeetings/lps/
Server/tomcat-5.0.24/bin/startup.sh

在浏览器中http://192.168.1.7:8080/lps-4.7.1/
就能看到一个OpenLaszlo Quick Index页面
到这里就证明你的LPS安装成功

8、配置Openmeetings客户端到OpenLaszlo(lps)中
说明:在Openmeetings的官方网站上找了几个客户端,都没有实验成功(有的是显示乱码,而且连接不上,有的根本就出现错误,提示缺少文件),我就把Openmeetings服务端改造了一下(删除了一些文件),也可以使用,但不知道有没有什么效果。
如果说,各位网友能知道解决的办法,请与我联系,先谢过!
我把自己的openmeetingsclient.tar传到服务器上,
里面内容如下(图9)
9
tar xvf openmeetingsclient.tar
mv openmeetingsclient /openmeetings/lps/Server/lps-4.7.1/client
cd /openmeetings/lps/Server/lps-4.7.1/client
vim config.xml

同样是改下面的内容
<!--<rtmphostlocal>192.168.254.182</rtmphostlocal>-->
<rtmphostlocal>192.168.1.7</rtmphostlocal>
这时候我们就能用http://192.168.1.7:8080/lps-4.7.1/client时行浏览和登陆了
界面和服务端是一样的,所以这里就不给图了,大家自己试吧!

9、一些问题期待各位指点
a、在浏览器的左下角,始终会有(剩下1项)的提示,不知道是什么原因(图)
b、在会议室里面上传文件的是时候如果有中文,传上去后就变乱码,除非是把改成UTF-8格式的才正常,这个如何解决?
c、会议定中一些快捷键不能用
d、如何把Red5的启动命令设置成开机启动,我试过好几个,没有通过,只有Openoffice这个能实现开机启动
网友lillian是用下面的方法实现的,大家可以试试
在red5.sh里将/usr/bin/java 和/usr/local/bin/java改成我的java地址,保存后,再用
echo 'cd /usr/././red5’>>/etc/rc.local
echo './red5.sh&'>>/etc/rc.local
感谢lillian给出的解决方案。
e、其它一些还没有发现的问题,希望知道和了解的,我们一起学习!

50 条留言  访客:30 条  博主:20 条

  1. 文章是你写的吗?不如加我3635651,谢谢

  2. Running on Linux
    Starting Red5
    Exception in thread “main” java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    启动/usr/bin/nohup ./red5.sh &出现以上错误。应该是java版本不正确。但是我java-1.6.0-openjdk,java-1.6.0-openjdk-devel这两个都已经安装了。现在不清楚那个地方的版本不对。应该怎么检查,怎么修正错误?

  3. avatar emisquannes

    ozw9wZ6z3Q

1 3 4 5

给我留言

Copyright © 羽飞博客 保留所有权利.   Ality主题 皖ICP备14013844号-1

用户登录